Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: glClear seems to fail

  1. #1
    Junior Member Newbie
    Join Date
    Jul 2014
    Posts
    2

    glClear seems to fail

    Hello folks :-)

    i'am currently trying to programm an openGL overlay for another programm. I'am using sdl as the Window manager.

    my problem:

    i got 2 test programms.

    - the first one is a simple console application. The code works fine everything works as expected.

    - the second programm is a QT-GUI-Application. The drawing also works excepted that the glClear don't seems to work.

    in both programms the drawing code is 100% the same!

    i create a seperate thread in both programms (std::thread)

    does anyone got the same situation or knows a solution how to resolve the problem?


    thanks alot and greetings from germany!

  2. #2
    Senior Member OpenGL Pro
    Join Date
    Jan 2007
    Posts
    1,215
    Are you clearing both the color and depth buffers, or just the depth buffer? If the latter, there are some specific reasons why a clear may fail (one of them is that GL didn't give you a depth buffer during startup), so it's important to know.

  3. #3
    Junior Member Newbie
    Join Date
    Jul 2014
    Posts
    2
    Okay.. i outsourced it into dll and now it woks.. you can close the topic // thanks for your answer!
    Last edited by hamburger; 07-10-2014 at 04:59 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •