Hi, I have an old mac from 07'. I use programs like photoshop, premier, and I just started using After effects.
After effects requires Open GL 2.0 or higher, which my graphics card, Intel GMA 950 64...