Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Search:

Type: Posts; User: t_guen03

Search: Search took 0.00 seconds.

  1. First of all you are certainly asking at the...

    First of all you are certainly asking at the wrong place and this is for sure not an "advanced" OpenGL question. Secondly a bunch of text does not help to find your bug, because you are just...
  2. Ah now i see what you mean. If i don't find an...

    Ah now i see what you mean. If i don't find an solution for this problem, then i'll have to go with your solution, even if this means a lot of refactoring for me, without going further into detail.
    ...
  3. Yes, could be the same issue i have. Could you...

    Yes, could be the same issue i have.

    Could you explain what you mean with "ditch the PBO intermediary"?
  4. Replies
    2
    Views
    519

    Use fences. Add this after your draw call: ...

    Use fences.

    Add this after your draw call:

    GLsync fence = glFenceSync(GL_SYNC_GPU_COMMANDS_COMPLETE, 0)

    and then wait for it to finish:

    if (glClientWaitSync(fence,...
  5. Performance problem PBO + glCompressedTexSubImage3D + Texture Array

    Hello there,

    i've a problem with updating a texture array with compressed data per glCompressedTexSubImage3D.

    I have an PBO which stores the compressed data, which i want to use to update a 2D...
  6. Thread: std140 layout

    by t_guen03
    Replies
    5
    Views
    1,147

    I see. Thanks for the clarification.

    I see. Thanks for the clarification.
  7. Thread: std140 layout

    by t_guen03
    Replies
    5
    Views
    1,147

    Thanks for your answers, i'll try that out...

    Thanks for your answers, i'll try that out mhagain.

    Regarding:




    If i understand it right, then the alignment will always be rounded up to the base alignment of a vec4.
    Isn't this then...
  8. Thread: std140 layout

    by t_guen03
    Replies
    5
    Views
    1,147

    std140 layout

    Hey there,

    i've a question regarding the std140 layout.

    In my shader i have a uniform block like this:

    layout(std140) uniform GeometryInfos {
    ivec2 info[32];
    };
  9. Replies
    2
    Views
    622

    Awesome. I was still fixing the errors in my...

    Awesome.
    I was still fixing the errors in my post and you already gave me the answer.
    Thank you very much, i'll try this out.

    Edit: As expected: It solved my problem. Thanks again : )
  10. Replies
    2
    Views
    622

    Strange Behaviour of glTexSubImage3D

    Hi,

    i am striking a problem, which i can't figure out by myself.
    The situation is like this. I create a 2D array texture, for which i allocate memory with (glTexStorage3D). The Texture has got...
Results 1 to 10 of 10